Warthog Joystick fubar'd

Anything pilot related can be discussed here

Warthog Joystick fubar'd

Postby Ian Robson » Fri Jul 13, 2018 7:27 pm

Hi all,

I've just raised a ticket with Thrustmaster as after disconnecting and reconnecting my joystick grip from the base, the device is now only showing as 'HOTAS Joystick Bootloader'. I've spent the afternoon searching google and trying various solutions but without success. Same symptoms as the article below, but the DIN socket looks flush with the bracket in the base - https://support.thrustmaster.com/en/kb/111-en/

I've tried this - http://ts.thrustmaster.com/faqs/eng/thr_eng_00140.pdf on 3 different PC's.

So it looks like I am grounded until I can get this fixed.
Pilot Officer Ian Robson - RAF Air UK

Image
User avatar
Ian Robson
 
Posts: 30
Joined: Thu May 24, 2018 9:49 pm

Re: Warthog Joystick fubar'd

Postby Flyco » Fri Jul 13, 2018 8:02 pm

The miniature DIN socket connecting the handle to the base is not the most robust of items. I presume you have tried disconnecting and reconnecting. The trick is not to use the screw to force them together; instead just try and ease the handle into the base, after checking that the plug and sockets orientations are right. Then connect and switch on. If it still doesn’t work, try gently rocking the handle.

You almost certainly cannot do any damage, by connecting and disconnecting the two parts.

I presume you do not have an extension. If you do, the cable connecting tthrough the extension can also fail.
Squadron Leader Alan Johnson - RAFAir UK
Image
Image Image Image Image
Flyco
Site Admin
 
Posts: 1180
Joined: Sun Jan 11, 2015 2:30 pm
Location: York

Re: Warthog Joystick fubar'd

Postby Ian Robson » Fri Jul 13, 2018 8:33 pm

Thanks Alan,

I've tried it with and without the extension cable with no joy. I have connected them without using the screw collar, but I haven't tried gently rocking the handle, so I will definitely give that a go.

Thanks,
Ian
Pilot Officer Ian Robson - RAF Air UK

Image
User avatar
Ian Robson
 
Posts: 30
Joined: Thu May 24, 2018 9:49 pm

Re: Warthog Joystick fubar'd

Postby ANT (EGNF) UK » Fri Jul 13, 2018 11:47 pm

This happened to me this time last year, got a new WH and tried fitting an extension but the same happened when I disconnected the stick from the base whilst the base was still USB connected to my PC, it never worked again. Luckily the company I bought it from sent me a new set, after I wrote a full A4 page explaining all the online tips and suggestions including Thrustmaster's own, that I tried and they couldn't argue. My suggestion to all owners is to never dismantle the stick while the USB is still powered / connected.

Sorry to hear you are having a similar issue, I feel it's just a matter of time before the same happens again to my current stick, somehow.

It's appalling that the company is allowed to sell the sticks at all anymore, considering nearly everyone has some kind of issue with them. Such a shame, as they could be the best.
ANT (EGNF) UK
 
Posts: 11
Joined: Tue Mar 13, 2018 10:47 pm
Location: Sheffield, South Yorkshire

Re: Warthog Joystick fubar'd

Postby Ian Robson » Mon Jul 16, 2018 12:40 pm

I'm completely amazed and delighted but running the article below again today I've managed to get the joystick working again. Didn't do anything differently, perhaps leaving it unplugged for a couple of days helped :?: :?:

http://ts.thrustmaster.com/faqs/eng/thr_eng_00140.pdf
Pilot Officer Ian Robson - RAF Air UK

Image
User avatar
Ian Robson
 
Posts: 30
Joined: Thu May 24, 2018 9:49 pm

Re: Warthog Joystick fubar'd

Postby Neil Willis » Mon Jul 16, 2018 12:50 pm

Glad to hear it is sorted.
Group Captain Neil Willis - RAF Air UK
ImageImageImageImageImage
User avatar
Neil Willis
Site Admin
 
Posts: 3542
Joined: Tue May 27, 2014 2:44 pm
Location: West Midlands


Return to General Pilot Chat

cron